Forums Zelda Solarus

Zelda => Zelda : Mercuris' Chest => Bugs => Topic started by: NewGaymer on 26 Juin 2006 à 17:19

Title: Bug à l'install
Post by: NewGaymer on 26 Juin 2006 à 17:19
Bonjour , j'ai téléchargé la démo 2.0 , mais quand je veux lancer l'install , ça bloque ensuite ya une message d'erreur de windows , qui dit comme quoi , le programme a effectué une erreur , et qu'il doit imperativement etre arreté !

Est-ce un problème sur mon pc , ou un bug du programme ?
Title: Re: Bug à l'install
Post by: ed_cool on 26 Juin 2006 à 17:27
Avec un affichage et deux boutons: "Send", "Don't Send"?

Ça m'est arrivé, et je ne pouvais que télécharger la démo 1.0 correctement, sauf en allan sur un des autres PC à côté de moi, l'installé à partir de celui-ci sur le réseau, et le mettre de mon autre PC, dans le répertoire "Program Files".
 ^_^

Sinon, il te reste la démo 1.0, quii est identique à la démo 2.0, sauf sous TGF.  :)
Title: Re: Bug à l'install
Post by: HCkev on 26 Juin 2006 à 18:45
Sauf que la v2 est fait avec le moteur final, et doit sûrement contenir moins de bugs ;)
Title: Re: Bug à l'install
Post by: Christopho on 26 Juin 2006 à 19:52
J'en ai marre, j'ai essayé des tonnes de logiciels de création de programmes d'installation et pas moyen d'en trouver un qui fasse que l'installeur marche chez tout le monde.
S'il y en a qui connaissent des programmes d'installation qui marchent, aidez-moi :P
Je vais sûrement faire une version zip (comme Zelda Solarus) mais c'est chiant car il faut que les gens installant les polices d'écran manuellement.
Title: Re: Bug à l'install
Post by: Noxneo on 26 Juin 2006 à 19:58
Pourquoi t'essayes pas Inno Setup ? C'est rapide, populaire, pratique, et y'a des chances pour que ca marche partout ^^
Title: Re: Bug à l'install
Post by: lelinuxien on 26 Juin 2006 à 19:59
Le mieux serait de faire une archive ZIP (ou autre format) auto-extractible. Mais le problème serait pour les raccourcis.
Title: Re: Bug à l'install
Post by: Christopho on 26 Juin 2006 à 20:10
Une archive zip auto-extractible ne permet d'installer des polices automatiquement, si ?
Inno Setup je connais pas, je vais essayer.
Merci pour votre aide ;)
Title: Re: Bug à l'install
Post by: lelinuxien on 26 Juin 2006 à 20:14
Une archive zip auto-extractible ne permet d'installer des polices automatiquement, si ?
Inno Setup je connais pas, je vais essayer.
Merci pour votre aide ;)
Ca je ne sais pas. Je pense que tout est décompressé dans le même répertoire. Mais il est possible d'exécuter un fichier à la fin de la décompression. Peut-être devrais-tu essayer d'exécuter un script .bat qui copierait les polices, raccourcis,...
Title: Re: Bug à l'install
Post by: leboss on 28 Juin 2006 à 08:17
Christopho, tout logiciel est source de bug à la bas eà mon gout. Ce qui veux dire que je connais pas un logiciel qui fonctionne chez tout le monde.
Je pense qu'il est impossible de satisfaire exactement tout le monde.
C'est d'ailleurs cette raison que pour mon jeu amateur  je propose le zip et le .exe. En se disant que le zip est le cas le plus simple pour les utilisateurs.
Title: Re: Bug à l'install
Post by: HCkev on 28 Juin 2006 à 17:49
Pourquoi ne pas utiliser deux installateurs ? La personne essaie le premier, et si ça marche pas, elle essaie le deuxième. Si l'un des deux ne fonctonne pas, il y a bien de chances que le deuxième fonctionne, non ? :)
Title: Re: Bug à l'install
Post by: Xenon3000 on 17 Août 2006 à 19:45
Je remonte ce topic car le bug en question vient de m'arriver...j'ai voulut rejouer à M'C sur ma nouvelle machine et paf...le message d'erreur à l'installation.

J'en ai marre, j'ai essayé des tonnes de logiciels de création de programmes d'installation et pas moyen d'en trouver un qui fasse que l'installeur marche chez tout le monde.

Instal Creator de Clickteam ne fonctionne pas ?
Title: Re: Bug à l'install
Post by: HCkev on 17 Août 2006 à 22:18
C'est ce qu'il utilise, je pense. Et non, aparemment, ça marche pas chez tout le monde :huh:
Title: Re: Bug à l'install
Post by: Xenon3000 on 18 Août 2006 à 08:54
Non je croi qu'il utilise Inbox de Palmsoft pour l'installeur de Mercuris Chest.

Edit: j'en suis même sûr ! :)
Title: Re: Bug à l'install
Post by: Christopho on 18 Août 2006 à 14:10
Oui mais j'utilise ça parce que certains avaient des problèmes avec Install Maker (erreur CRC), tout comme pour Zelda Solarus d'ailleurs...
Je n'ai pas encore essayé Inno Setup, mais je le ferai quand j'aurai le temps :P
Title: Re: Bug à l'install
Post by: Xenon3000 on 18 Août 2006 à 14:16
Sinon quelqu'un pourrai m'envoyer le jeu en Zip ?

Merci.
Title: Re: Bug à l'install
Post by: Xenon3000 on 25 Août 2006 à 23:55
Bon il est 1 heure du mat et j'ai réussi à corriger ca... il suffit :

d'aller dans "C:\WINDOWS\system32\Macromed\Flash" et de supprimé le fichier "flash.ocx" (enfin le suprimez pas pour le moment mettez le dans un autre dossier.

EDIT: par contre là pas cool il vient de me fermer le jeu avec un gros message d'erreur.
Title: Re: Bug à l'install
Post by: HCkev on 26 Août 2006 à 04:59
Hein ? Je comprend pas.. Qu'est-ce que Flash a à voir avec l'installateur ? :mellow:




...À moins que l'installateur soit fait avec flash :P comme quoi qu'on peut bien camoufler un Flash B)
Title: Re: Bug à l'install
Post by: Xenon3000 on 26 Août 2006 à 09:56
Oui c'est vrai mais pourtan il va bien bricoler dans ce dossier...